开云体育

ctrl + shift + ? for shortcuts
© 2025 开云体育

Re: Question about connecting from Cisco/Sparcstation


 

Find my (working) cisco and SunLink/X.25 configurations below:

!
! Last configuration change at 07:54:53 MEST Sat Dec 16 2023
!
version 15.0
service pad to-xot
service pad from-xot
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$ARw/$HyvEhZULktN8tKEGq6Fjt1
!
no aaa new-model
!
!
!
clock timezone MEST 2
!
dot11 syslog
ip source-route
no ip routing
!
!
no ip cef
!
!
ip domain name
ip name-server 192.168.23.1
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
x25 routing
x25 call-record
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FCZ1250708P
!
redundancy
!
!
!
!
!
!
dlsw local-peer peer-id 192.168.23.2
dlsw remote-peer 0 tcp 192.168.23.3
!
!
!
!
interface FastEthernet0/0
?ip address 192.168.23.2 255.255.255.0
?no ip route-cache
?shutdown
?duplex half
?speed auto
?no cdp enable
?no mop enabled
?!
!
interface FastEthernet0/1
?ip address 192.168.23.2 255.255.255.0
?no ip route-cache
?duplex half
?speed 10
?no cdp enable
?!
!
interface Serial0/0/0
?description Sun SPARCstation IPX
?no ip address
?encapsulation x25 dce
?no ip route-cache
?clock rate 9600
?no cdp enable
?!
!
interface Serial0/0/1
?description VAX 4000-105A EUGENE::
?no ip address
?encapsulation x25 dce
?no ip route-cache
?x25 address 23000100
?clock rate 9600
?no cdp enable
?!
!
interface Serial0/1/0
?no ip address
?encapsulation sdlc
?no ip route-cache
?shutdown
?no keepalive
?clock rate 9600
?sdlc role primary
?sdlc vmac 4000.0999.0100
?sdlc address C1
?sdlc xid C1 01700019
?sdlc partner 4000.1020.1000 C1
?sdlc dlsw C1
?!
!
interface Serial0/1/1
?no ip address
?no ip route-cache
?shutdown
?clock rate 2000000
?!
!
ip default-gateway 192.168.23.1
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging facility local4
logging source-interface FastEthernet0/0
logging 192.168.178.11
logging 192.168.2.49
no cdp run

!
!
!
!
!
x25 route ^230002.. interface Serial0/0/1
x25 route ^230003.. interface Serial0/0/0
x25 route ^(...)(...) xot dns \2.\
x25 route .* clear
x25 host 23000100
!
control-plane
?!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
?password cisco
?login
?transport input all
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 192.168.23.1
end

# DON'T CHANGE THE ORDER OF THE PARAMETERS
# THERE MUST BE A VALUE ASSOCIATED WITH EACH PARAMETER
# THERE MUST BE AT LEAST ONE SPACE BETWEEN THE PARAMETER'S VALUE AND THE '#'
#
# To change a specific parameter, first look for the the parameter
# name in the comments (starting with '#'), then modify the value at the
# beginning of the line.
#
0 ? ? ? ? ? ? ? #int ? ? linkid; ?A non-negative integer less than the
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? ? total number of links.? There should
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? ? always be alink 0, as this is used as
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? ? the default link.
? ? ? ? ? ? ? ? #
1 ? ? ? ? ? ? ? #int ? ? on; ? ? ?0 or 1. ?0 will cause the link to be
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? ? deactivated, and 1 will cause it to
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? ? be activated.
? ? ? ? ? ? ? ? #
? ? ? ? #HDLC Level: HDLC_PARAM
4500 ? ? ? ? ? ?#ushort ?hp_t1; ? T1 - retransmission timer (msec)
2000 ? ? ? ? ? ?#ushort ?hp_t2; ? T2 - max delay before ACK (msec)
18000 ? ? ? ? ? #ushort ?hp_t3; ? T3 - max idle link time (msec)
500 ? ? ? ? ? ? #ushort ?hp_tick; resolution of timer (tick)
134 ? ? ? ? ? ? #ushort ?hp_n1; ? N1 - max frame size - bytes
10 ? ? ? ? ? ? ?#u_char ?hp_n2; ? N2 - max retries of T1
0 ? ? ? ? ? ? ? #u_char ?hp_xcntl;extended control - mod 128
7 ? ? ? ? ? ? ? #u_char ?hp_k; ? ?K - window size
3 ? ? ? ? ? ? ? #u_char ?hp_addr; address - 3 for DTE, 1 for DCE
? ? ? ? ? ? ? ? # ? ? ? ?when connecting two SunLink X.25 stations together
? ? ? ? ? ? ? ? # ? ? ? ?without a PDN, you must specify one station to be
? ? ? ? ? ? ? ? # ? ? ? ?DTE (i.e. 3) and the other one to be DCE (i.e. 1)
? ? ? ? ? ? ? ? #
? ? ? ? ? ? ? ? #
? ? ? ? #Packet Level: L3_PARAM
230-003-00 ? ? ?#host_address; includes DNIC (Data Network Identification
? ? ? ? ? ? ? ? # ? ? ?Code), NTN (Network Terminal Number), and
? ? ? ? ? ? ? ? # ? ? ?subaddress (if it is part of host address).
? ? ? ? ? ? ? ? # ? ? ?This host address is up to 14 digits long.
? ? ? ? ? ? ? ? # ? ? ?The DNIC, NTN, and subaddress must be separated
? ? ? ? ? ? ? ? # ? ? ?with hyphens.? The subaddress is optional - if
? ? ? ? ? ? ? ? # ? ? ?specified, it is used as the default subaddress
? ? ? ? ? ? ? ? # ? ? ?wherever applicable.? The full address of the
? ? ? ? ? ? ? ? # ? ? ?terminal (DNIC and NTN) must always be specified.
? ? ? ? ? ? ? ? # ? ? ?The portion of it that gets sent as the calling
? ? ? ? ? ? ? ? # ? ? ?address in a call request can be controlled by
? ? ? ? ? ? ? ? # ? ? ?the setting of the src_opt parameter (see below).
? ? ? ? ? ? ? ? # ? ? ?If src_opt is set to 2 (meaning send only subaddress
? ? ? ? ? ? ? ? # ? ? ?for the calling address), and a subaddress is not
? ? ? ? ? ? ? ? # ? ? ?specified here, a null address will be sent.
? ? ? ? ? ? ? ? # ? ? ?When connecting to Transpac, 'null' may be sent
? ? ? ? ? ? ? ? # ? ? ?in this way.
? ? ? ? ? ? ? ? #
8 ? ? ? ? ? ? ? #u_char ?packet_sequence;
? ? ? ? ? ? ? ? # ? ? ?modulo sequence of level 3. suggested= 8
? ? ? ? ? ? ? ? # ? ? ?8, 128 ( in decimal )
? ? ? ? ? ? ? ? #
2 ? ? ? ? ? ? ? #u_char ?default_wndsize;
? ? ? ? ? ? ? ? # ? ? ?default window size for all virtual circuits
? ? ? ? ? ? ? ? # ? ? ?suggested= 2
? ? ? ? ? ? ? ? # ? ? ?1 ~ 7 ? if packet_sequence= 8
? ? ? ? ? ? ? ? # ? ? ?1 ~ 127 if packet_sequence= 128
? ? ? ? ? ? ? ? # ? ? ?( in decimal )
? ? ? ? ? ? ? ? #
10 ? ? ? ? ? ? ?#u_char ? ?default_thruput;
? ? ? ? ? ? ? ? # ? ? default throughput for all virtual circuits
? ? ? ? ? ? ? ? # ? ? suggested= 10 ( 9600 bps )
? ? ? ? ? ? ? ? # ? ? 3= 75 ? ?8= 2400
? ? ? ? ? ? ? ? # ? ? 4= 150 ? 9= 4800
? ? ? ? ? ? ? ? # ? ? 5= 300 ?10= 9600
? ? ? ? ? ? ? ? # ? ? 6= 600 ?11= 19200
? ? ? ? ? ? ? ? # ? ? 7= 1200 12= 48000
? ? ? ? ? ? ? ? # ? ? ( bps in decimal )
? ? ? ? ? ? ? ? #
128 ? ? ? ? ? ? #ushort ? default_pktsize;
? ? ? ? ? ? ? ? # ? ? default packet size
? ? ? ? ? ? ? ? # ? ? suggested value= 128
? ? ? ? ? ? ? ? # ? ? 16, 32, 64, 128, 256, 512, or 1024
? ? ? ? ? ? ? ? #
1 ? ? ? ? ? ? ? #ushort ?lic; ?lowest ?one-way incoming lcn. suggested= 512
1 ? ? ? ? ? ? ? #ushort ?hic; ?highest one-way incoming lcn. suggested= 512
1 ? ? ? ? ? ? ? #ushort ?ltc; ?lowest ?two-way lcn. suggested= 512
1024 ? ? ? ? ? ?#ushort ?htc; ?highest two-way lcn. suggested= 575
1024 ? ? ? ? ? ?#ushort ?loc; ?lowest ?one-way outgoing lcn. suggested= 575
1024 ? ? ? ? ? ?#ushort ?hoc; ?highest one-way outgoing lcn. suggested= 575
? ? ? ? ? ? ? ? # ? ?4095 >= hoc >= loc >= htc >= ltc >= hic >= lic >= 1
? ? ? ? ? ? ? ? # ? ?( in decimal )
? ? ? ? ? ? ? ? #
180 ? ? ? ? ? ? #u_char ?t0; ?timeout limit after sending RESET REQUEST
? ? ? ? ? ? ? ? # ? ?packet. suggested= 180 ( seconds )
? ? ? ? ? ? ? ? #
200 ? ? ? ? ? ? #u_char ?t1; ?timeout limit after sending CALL REQUEST
? ? ? ? ? ? ? ? # ? ?packet. suggested= 200 ( seconds )
? ? ? ? ? ? ? ? #
180 ? ? ? ? ? ? #u_char ?t2; ?timeout limit after sending RESTART REQUEST
? ? ? ? ? ? ? ? # ? ?packet. suggested= 180 ( seconds )
? ? ? ? ? ? ? ? #
180 ? ? ? ? ? ? #u_char ?t3; ?timeout limit after sending CLEAR REQUEST
? ? ? ? ? ? ? ? # ? ?packet. suggested= 180 ( seconds )
? ? ? ? ? ? ? ? #
? ? ? ? ? ? ? ? # ? ?1 ~ 255 ( seconds in decimal ) for above four fields
? ? ? ? ? ? ? ? #
3 ? ? ? ? ? ? ? #u_char ?t0_retries;
1 ? ? ? ? ? ? ? #u_char ?t1_retries;
? ? ? ? ? ? ? ? # ? ? ? must be 1 to conform to CCITT X.25
3 ? ? ? ? ? ? ? #u_char ?t2_retries;
3 ? ? ? ? ? ? ? #u_char ?t3_retries;
? ? ? ? ? ? ? ? # ? ?number of retries before reporting error status
? ? ? ? ? ? ? ? # ? ?to X.25 MGMT socket.
? ? ? ? ? ? ? ? # ? ?1 ~ 255 ( attemps in decimal ) for above four fields
? ? ? ? ? ? ? ? #
2048 ? ? ? ? ? ?#u_short ? ? ? ?sendspace;
2048 ? ? ? ? ? ?#u_short ? ? ? ?recvspace;
0 ? ? ? ? ? ? ? #u_char ? ? ? ? D_bit;
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? This applies only to calls that are
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? originated.? For incoming calls, D bit
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? is always accepted.
0 ? ? ? ? ? ? ? #u_char ? ? ? ? non_standard_diag_code;
? ? ? ? ? ? ? ? # ? ? ? This permits the setting of non-standard
? ? ? ? ? ? ? ? # ? ? ? diagnostic code in clear indication and clear
? ? ? ? ? ? ? ? # ? ? ? confirmation packets.
? ? ? ? ? ? ? ? # ? ? ? 0= standard diagnostic code
? ? ? ? ? ? ? ? # ? ? ? 1= non-standard diagnostic codes
? ? ? ? ? ? ? ? # ? ? ? suggested value= 0
? ? ? ? ? ? ? ? #
0 ? ? ? ? ? ? ? #int ? ?dst_opt;
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? This parameter can have one of two values:
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? 0 or 1.? This parameter is relevant only
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? for local calls.? If 0, the called address
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? field in the call request will be set to the
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? full address of the destination (DNIC+NTN+
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? subaddress).? If set to 1, only the NTN and
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? subaddress will be sent.
? ? ? ? ? ? ? ? #
0 ? ? ? ? ? ? ? #int ? ?src_opt;
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? This parameter can be 0, 1, or 2, and is
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? applicable to all calls (local or long
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? distance).? If set to 0, the calling address
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? field in the call request will be set to the
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? full address of the source (DNIC+NTN+
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? subaddress). If set to 1, only the NTN and
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? subaddress will be sent.? If set to 2, only
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? the subaddress will be sent.
? ? ? ? ? ? ? ? #
0 ? ? ? ? ? ? ? #int ? ?zero_opt;
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? This parameter can be 0, 1, or 2.? If set
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? to 0, the calling and called address fields
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? in the call request will be determined by
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? the setting of dst_opt and src_opt.? If set
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? to 1, a zero will be prepended to the
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? called address for long distance calls -
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? 0 will be prepended to aclling address also
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? if src_opt = 0.? If this parameter is set to
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? 2, it will behave as when it is set to 1,
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? except that 0 will be prepended for local
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? calls as well if dst_opt and src_opt
? ? ? ? ? ? ? ? # ? ? ? ? ? ? ? indicate that full address are to be used.
? ? ? ? ? ? ? ? #
? ? ? ? #Physical Level:
9600 ? ? ? ? ? ?# baud rate( bps ) of physical line( from either modem or
? ? ? ? ? ? ? ? # internal clocks ).

Am Fr., 15. Dez. 2023 um 23:30?Uhr schrieb Phillip Heller via <pheller=[email protected]>:

I can check my Cisco config tomorrow morning, but I recall running into something similar.? Try to adjust your profile to window size of 2 (both directions) and modulo 8, or disassociate the profile entirely.

Also, Wireshark has a comprehensive dissector for XOT, so it may prove helpful in troubleshooting and comparing with what xotpad negotiates.

Regards,

? Phil

On Dec 15, 2023, at 2:55?PM, Christopher Collet <ccolletpdp11@...> wrote:

?
I configured my Cisco as per the sample?configuration on the x25 website but it seems that I'm still missing something. Looks like the error is " ?XOT Call Confirm packet, Bad value for facility, Window size is not within permitted range." I'm able to connect to 471041 just fine from xotpad


Router#pad 471041
Trying 471041...
% Connection refused by remote host

Router#
*Dec 15 20:32:23.522: [193.219.181.219,1998/,25515]: XOT O P2 Call (18) 128 lci 1
*Dec 15 20:32:23.522: ? From (0): ?To (6): 471041
*Dec 15 20:32:23.522: ? Facilities: (6)
*Dec 15 20:32:23.522: ? ? Packet sizes: 1024 1024
*Dec 15 20:32:23.522: ? ? Window sizes: 15 15
*Dec 15 20:32:23.522: ? Call User Data (4): 0x01000000 (pad)
*Dec 15 20:32:23.682: [193.219.181.219,1998/,25515]: XOT I P2 Call Confirm (11) 128 lci 1
*Dec 15 20:32:23.682: ? From (0): ?To (0):
*Dec 15 20:32:23.682: ? Facilities: (6)
*Dec 15 20:32:23.682: ? ? Packet sizes: 1024 1024
*Dec 15 20:32:23.686: ? ? Window sizes: 15 15
*Dec 15 20:32:23.686: XOT Call Confirm packet, Bad value for facility, Window size is not within permitted range
*Dec 15 20:32:23.686: [193.219.181.219,1998/,25515]: XOT O P2 Clear (5) 128 lci 1
*Dec 15 20:32:23.686: ? Cause 3, Diag 66 (Invalid facility request/Facility parameter not allowed)
*Dec 15 20:32:23.686: [193.219.181.219,1998/,25515]: XOT I P6 Data (5) Q 128 lci 1 PS 0 PR 0
*Dec 15 20:32:23.690: [193.219.181.219,1998/,25515]: XOT I P6 Data (107) 128 lci 1 PS 1 PR 0
*Dec 15 20:32:23.838: [193.219.181.219,1998/,25515]: XOT I P6 Clear Confirm (3) 128 lci 1

On Wed, Dec 13, 2023 at 12:27?PM Christopher Collet via <ccolletpdp11=[email protected]> wrote:
It doesn't look like the Sparcstation 1 has jumpers on the motherboard to set the serial ports to RS423... but I also have a Sparcstation 4 and a 10 so I guess I'll just use one of those instead. Thanks!

On Tue, Dec 12, 2023 at 8:12?PM Dave Brown <dave@...> wrote:
Assuming the SparcStation 1 supports RS530 differential serial.? RS530 defines the cable, and it uses EIA/RS-423 electrical signaling.

Some Sparc serial ports can be set to RS423. I think you might get lucky with the SparcStation 1; and further assuming it’s similar to the 4 or 5; they could. ?


On Dec 12, 2023, at 7:17?PM, Christopher Collet <ccolletpdp11@...> wrote:

Hello everyone,

I'd like to connect my old Sparcstation 1 to Telebahn. I've got a Cisco 1841 with a WIC-2T, can I use a?CAB-SS-530MT cable to connect the WIC-2T directly to the serial port on the Sparcstation? And then run Sunlink on the Sparc to connect to Telebahn??

Btw my dad worked for Telenet back in the 80's and when I told him about this project, he said "why would anybody want to do that?"??

Join [email protected] to automatically receive all group messages.